webpack 4.0?跑太快了

今天查 webpack 文档, 发现版本已经是 4.6 了, 而 webpack 4.0 发布于 2月25日, 距今天不足两个月.

不知道是什么促使 webpack 上演版本大战, 也许有 parcel 的原因吧. 但我要说的是, webpack 4.0+ , 变得更难用了

首先独立出来一个 webpack-cli 就能坑老大一批人

其次说好的零配置(mode设置)也并不全面, 不设置 mode 编译时还有警告; 再加上我用 webpack 本来就不是冲着零配置去的, 我喜欢的就是灵活的配置(比如怎么将打包出来的代码兼容IE8)

然后, 很多插件没有跟上 webpack 的步伐, 导致使用报错. 其中不乏知名且使用率很高的插件如 html-webpack-plugin, extract text plugin

还有就是官方的文档, 更新也严重滞后. 4.0 就废除了 CommonsChunkPlugin , 但官方的文档里还是比比皆是(只有左边的版本号变成了 4.6.0)

4.0发布不久, 我就试用了一下整体流程, 第一个感觉就是坑多.加上文档的滞后, 体验非常不好

就连 CommonsChunkPlugin 废除后用什么, 我都查了老半天—-结论是新的配置项: optimization.splitChunks

好了, 不多说了. 建议保持观望, 不要升级到 4.0 以上—-起码应该等官方文档更新后再说

发表评论

电子邮件地址不会被公开。